Bug 号 7155407
已归档 05-JUN-2008 已更新 25-JUL-2008
产品 Oracle OLAP 产品版本 10.2.0.3
平台 Linux x86 平台版本 无数据
数据库版本 10.2.0.3 影响平台 Generic
优先级 Severe Loss of Service 状态 Development to Q/A
基本 Bug N/A 修复产品版本 11.2
问题陈述:
ERROR EXPORTING FROM 10.1, 10.2 OR 11.1 WITH 9.2 CLIENT AND OLAP NOT INSTALLED
--------------------------------------------------------------------------------
*** 06/05/08 08:06 am *** If you:
(1) Have OLAP linked into the Oracle executable
(2) Have not installed the APS component
(3) Are exporting from 10.1, 10.2 or 11.1, but using a 9.2 export client .
then you may fail the export with errors like this:
ORA-39127: unexpected error from call to export_string :=SYS.DBMS_AW_EXP.schema_info_exp('SYS',1,1,'09.02.00.06.00',newblock)
ORA-37002: Oracle OLAP failed to initialize. Please contact Oracle OLAP technical support.
ORA-33262: Analytic workspace EXPRESS does not exist.
*** 06/05/08 08:06 am *** (CHG: Asg->NEW OWNER)
*** 06/05/08 08:12 am *** If OLAP is actually not in use, then workarounds (only one or the other is necessary, not both) would be: .
1) Relink Oracle with the OLAP option turned off (olap_off make target) .
2) Remove the relevant entries from exppkgact$:
DELETE FROM sys.exppkgact$ WHERE package='DBMS_AW_EXP';
. Note that both of these will cause OLAP data to not be exported, so should only be performed if OLAP is not actually in use in this installation